What’s Vulnerable › Vulnerabilities
CVE-2025-0668: BOINC Server Multiple SQL Injections
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-07 · updated 2026-06-17
- Weakness: CWE-89
Description
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in BOINC Server allows Stored XSS.This issue affects BOINC Server: before 1.4.5.
Affected products
- BOINC Server: before 1.4.5 — fixed in 1.4.5
How to fix
Upgrade to a fixed version: BOINC Server 1.4.5. Check the vendor advisory for mitigations.
References
- https://www.compass-security.com/fileadmin/Research/Advisories/2025_03_CSNC-2025-004_BOINC_multiple_SQLi.txt
- https://www.compass-security.com/fileadmin/Research/Advisories/2025_03_CSNC-2025-004_BOINC_multiple_SQLi.txt
Get alerted when CVE-2025-0668 or the next vulnerability affects your stack