What’s Vulnerable › Vulnerabilities
CVE-2025-0682: ThemeREX Addons <= 2.33.0 - Authenticated (Contributor+) Local File Inclusion via Shortcode
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-25 · updated 2026-06-17
- Weakness: CWE-98
Description
The ThemeREX Addons plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 2.33.0 via the 'trx_sc_reviews' shortcode 'type' attribute. This makes it possible for authenticated attackers, with contributor-level and above permissions, to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where php file type can be uploaded and included.
Affected products
- ThemeREX Addons: before 2.34.0 — fixed in 2.34.0
How to fix
Upgrade to a fixed version: ThemeREX Addons 2.34.0. Check the vendor advisory for mitigations.
References
- https://themeforest.net/item/qwery-multipurpose-business-wordpress-theme/29678687
- https://www.wordfence.com/threat-intel/vulnerabilities/id/15a9718f-f877-4e33-8f7a-950791c4ca85?source=cve
Get alerted when CVE-2025-0682 or the next vulnerability affects your stack