What’s Vulnerable › Vulnerabilities
CVE-2025-0741: Improper Access Control vulnerability in EmbedAI
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-30 · updated 2026-06-17
- Weakness: CWE-284
Description
An Improper Access Control vulnerability has been found in EmbedAI 2.1 and below. This vulnerability allows an authenticated attacker to write messages into other users chat by changing the parameter "chat_id" of the POST request "/embedai/chats/send_message".
Affected products
- EmbedAI: before 2.1 — fixed in 2.1
How to fix
Upgrade to a fixed version: EmbedAI 2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0741 or the next vulnerability affects your stack