What’s Vulnerable › Vulnerabilities
CVE-2025-0746: Reflected Cross-Site Scripting vulnerability in EmbedAI
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
A Reflected Cross-Site Scripting vulnerability has been found in EmbedAI 2.1 and below. This vulnerability allows an authenticated attacker to craft a malicious URL leveraging the"/embedai/users/show/<SCRIPT>" endpoint to inject the malicious JavaScript code. This JavaScript code will be executed when a user opens the malicious URL.
Affected products
- EmbedAI: before 2.1 — fixed in 2.1
How to fix
Upgrade to a fixed version: EmbedAI 2.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0746 or the next vulnerability affects your stack