What’s Vulnerable › Vulnerabilities
CVE-2025-0755: MongoDB C Driver bson library may be susceptible to buffer overflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-18 · updated 2026-06-17
- Weakness: CWE-122
Description
The various bson_append functions in the MongoDB C driver library may be susceptible to buffer overflow when performing operations that could result in a final BSON document which exceeds the maximum allowable size (INT32_MAX), resulting in a segmentation fault and possible application crash. This issue affected libbson versions prior to 1.27.5, MongoDB Server v8.0 versions prior to 8.0.1 and MongoDB Server v7.0 versions prior to 7.0.16
Affected products
- MongoDB Inc libbson: before 1.27.5 — fixed in 1.27.5
- MongoDB: from 7.0.0 before 7.0.16; 8.0.0 — fixed in 7.0.16
How to fix
Upgrade to a fixed version: MongoDB Inc libbson 1.27.5; MongoDB 7.0.16. Check the vendor advisory for mitigations.
References
- https://jira.mongodb.org/browse/CDRIVER-5601
- https://jira.mongodb.org/browse/SERVER-94461
- https://lists.debian.org/debian-lts-announce/2025/05/msg00012.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00027.html
Get alerted when CVE-2025-0755 or the next vulnerability affects your stack