What’s Vulnerable › Vulnerabilities
CVE-2025-0764: wpForo Forum <= 2.4.1 - Authenticated (Subscriber+) Arbitrary File Read in update
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-28 · updated 2026-06-17
- Weakness: CWE-20
Description
The wpForo Forum plugin for WordPress is vulnerable to arbitrary file read due to insufficient input validation in the 'update' method of the 'Members' class in all versions up to, and including, 2.4.1. This makes it possible for authenticated attackers, with subscriber-level privileges or higher, to read arbitrary files on the server.
Affected products
- tomdever wpForo Forum: before 2.4.2 — fixed in 2.4.2
How to fix
Upgrade to a fixed version: tomdever wpForo Forum 2.4.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3245711/wpforo
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8cd8ffcb-0a24-4e0a-a9f9-23501742715f?source=cve
Get alerted when CVE-2025-0764 or the next vulnerability affects your stack