What’s Vulnerable › Vulnerabilities
CVE-2025-0801: RateMyAgent Official <= 1.4.0 - Cross-Site Request Forgery to API Key Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-28 · updated 2026-06-17
- Weakness: CWE-352
Description
The RateMyAgent Official plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.4.0. This is due to missing or incorrect nonce validation on the 'rma-settings-wizard'. This makes it possible for unauthenticated attackers to update the plugin's API key via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- RateMyAgent Official: before 1.5.0 — fixed in 1.5.0
How to fix
Upgrade to a fixed version: RateMyAgent Official 1.5.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3244718%40ratemyagent-official&new=3244718%40ratemyagent-official&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/ratemyagent-official/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b559017c-f1d2-4f18-bfb6-e52f05910e34?source=cve
Get alerted when CVE-2025-0801 or the next vulnerability affects your stack