What’s Vulnerable › Vulnerabilities
CVE-2025-0804: ClickWhale – Link Manager, Link Shortener and Click Tracker for Affiliate Links & Link Pages <= 2.4.1 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The ClickWhale – Link Manager, Link Shortener and Click Tracker for Affiliate Links & Link Pages plugin for WordPress is vulnerable to Stored Cross-Site Scripting via link titles in all versions up to, and including, 2.4.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- ClickWhale – Link Manager, Link Shortener and Click Tracker for Affiliate Links & Link Pages: before 2.4.2 — fixed in 2.4.2
How to fix
Upgrade to a fixed version: ClickWhale – Link Manager, Link Shortener and Click Tracker for Affiliate Links & Link Pages 2.4.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3219341/clickwhale/tags/2.4.2/includes/admin/links/Clickwhale_Links_List_Table.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bf41b5e1-610e-4159-9325-f7a694380050?source=cve
Get alerted when CVE-2025-0804 or the next vulnerability affects your stack