What’s Vulnerable › Vulnerabilities
CVE-2025-0808: Houzez Property Feed <= 2.4.21 - Cross-Site Request Forgery to Property Feed Export Deletion
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The Houzez Property Feed plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.4.21. This is due to missing or incorrect nonce validation on the "deleteexport" action. This makes it possible for unauthenticated attackers to delete property feed exports via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- propertyhive Houzez Property Feed: before 2.4.22 — fixed in 2.4.22
How to fix
Upgrade to a fixed version: propertyhive Houzez Property Feed 2.4.22. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3235031/houzez-property-feed/trunk/includes/class-houzez-property-feed-export.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6fd866ac-6094-4f76-9fba-69494381214c?source=cve
Get alerted when CVE-2025-0808 or the next vulnerability affects your stack