What’s Vulnerable › Vulnerabilities
CVE-2025-0811: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-27 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue has been discovered in GitLab CE/EE affecting all versions from 17.7 before 17.8.6, 17.9 before 17.9.3, and 17.10 before 17.10.1. Improper rendering of certain file types leads to cross-site scripting.
Affected products
- GitLab: from 17.7.0 before 17.8.6; from 17.9.0 before 17.9.3; 17.10.0 — fixed in 17.8.6, 17.9.3
How to fix
Upgrade to a fixed version: GitLab 17.8.6, 17.9.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0811 or the next vulnerability affects your stack