What’s Vulnerable › Vulnerabilities
CVE-2025-0822: Bit Assist <= 1.5.2 - Path Traversal to Authenticated (Subscriber+) Arbitrary File Read via fileID Parameter
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-15 · updated 2026-06-17
- Weakness: CWE-23
Description
Bit Assist plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.5.2 via the fileID Parameter. This makes it possible for authenticated attackers, with Subscriber-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.
Affected products
- bitpressadmin Chat Widget: Floating Customer Support Button for 30+ Channels, Supporting SMS, Calls, and Chat – Bit Assi: before 1.5.3 — fixed in 1.5.3
How to fix
Upgrade to a fixed version: bitpressadmin Chat Widget: Floating Customer Support Button for 30+ Channels, Supporting SMS, Calls, and Chat – Bit Assi 1.5.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/bit-assist/tags/1.5.2/backend/app/HTTP/Controllers/DownloadController.php#L65
- https://plugins.trac.wordpress.org/changeset/3239816/#file3
- https://wordpress.org/plugins/bit-assist/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/de9b0eba-5d2b-427c-a199-88bf96c26f5e?source=cve
Get alerted when CVE-2025-0822 or the next vulnerability affects your stack