What’s Vulnerable › Vulnerabilities
CVE-2025-0838: Heap Buffer overflow in Abseil
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-21 · updated 2026-06-17
- Weakness: CWE-190
Description
There exists a heap buffer overflow vulnerable in Abseil-cpp. The sized constructors, reserve(), and rehash() methods of absl::{flat,node}hash{set,map} did not impose an upper bound on their size argument. As a result, it was possible for a caller to pass a very large size that would cause an integer overflow when computing the size of the container's backing store, and a subsequent out-of-bounds memory write. Subsequent accesses to the container might also access out-of-bounds memory. We recommend upgrading past commit 5a0e2cb5e3958dd90bb8569a2766622cb74d90c1
Affected products
- Abseil Common Libraries: before 20250127.0 — fixed in 20250127.0
- Debian Linux: 11.0
How to fix
Upgrade to a fixed version: Abseil Common Libraries 20250127.0. Check the vendor advisory for mitigations.
References
- https://github.com/abseil/abseil-cpp/commit/5a0e2cb5e3958dd90bb8569a2766622cb74d90c1
- https://lists.debian.org/debian-lts-announce/2025/04/msg00012.html
Get alerted when CVE-2025-0838 or the next vulnerability affects your stack