What’s Vulnerable › Vulnerabilities
CVE-2025-0840: GNU Binutils objdump.c disassemble_bytes stack-based overflow
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-01-29 · updated 2026-06-17
- Weakness: CWE-119
Description
A vulnerability, which was classified as problematic, was found in GNU Binutils up to 2.43. This affects the function disassemble_bytes of the file binutils/objdump.c. The manipulation of the argument buf leads to stack-based buffer overflow. It is possible to initiate the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 2.44 is able to address this issue. The identifier of the patch is baac6c221e9d69335bf41366a1c7d87d8ab2f893. It is recommended to upgrade the affected component.
Affected products
- GNU Binutils: before 2.44 — fixed in 2.44
How to fix
Upgrade to a fixed version: GNU Binutils 2.44. Check the vendor advisory for mitigations.
References
- https://sourceware.org/bugzilla/attachment.cgi?id=15882
- https://sourceware.org/bugzilla/show_bug.cgi?id=32560
- https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=baac6c221e9d69335bf41366a1c7d87d8ab2f893
- https://vuldb.com/?ctiid.293997
- https://vuldb.com/?id.293997
- https://vuldb.com/?submit.485255
- https://www.gnu.org/
Get alerted when CVE-2025-0840 or the next vulnerability affects your stack