What’s Vulnerable › Vulnerabilities
CVE-2025-0859: Post and Page Builder by BoldGrid <= 1.27.6 - Path Traversal to Authenticated (Contributor+) Arbitrary File Read via template_via_url Function
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-06 · updated 2026-06-17
- Weakness: CWE-22
Description
The Post and Page Builder by BoldGrid – Visual Drag and Drop Editor plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 1.27.6 via the template_via_url() function. This makes it possible for authenticated attackers, with Contributor-level access and above, to read the contents of arbitrary files on the server, which can contain sensitive information.
Affected products
- boldgrid Post and Page Builder by BoldGrid – Visual Drag and Drop Editor: before 1.27.7 — fixed in 1.27.7
How to fix
Upgrade to a fixed version: boldgrid Post and Page Builder by BoldGrid – Visual Drag and Drop Editor 1.27.7. Check the vendor advisory for mitigations.
References
- https://github.com/BoldGrid/post-and-page-builder/pull/638/commits/10e4d1d96fd2735379049259d15896fa6dd35471
- https://plugins.trac.wordpress.org/browser/post-and-page-builder/trunk/includes/class-boldgrid-editor-preview.php#L178
- https://plugins.trac.wordpress.org/changeset?old=3234175&old_path=post-and-page-builder%2Ftags%2F1.27.7%2Fincludes%2Fclass-boldgrid-editor-preview.php&new=3234175&new_path=post-and-page-builder%2Ftags%2F1.27.7%2Fincludes%2Fclass-boldgrid-editor-preview.php
- https://wordpress.org/plugins/post-and-page-builder/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/111a1e7f-bc87-4130-a0b2-422d0f98afb6?source=cve
Get alerted when CVE-2025-0859 or the next vulnerability affects your stack