What’s Vulnerable › Vulnerabilities
CVE-2025-0901: PDF-XChange Editor Doc Object Out-Of-Bounds Read Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-11 · updated 2026-06-17
- Weakness: CWE-125
Description
PDF-XChange Editor Doc Object Out-Of-Bounds Read Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of PDF-XChange Editor. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the handling of Doc objects. The issue results from the lack of proper validation of user-supplied data, which can result in a read past the end of an allocated buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-25372.
Affected products
- PDF-XChange Editor: before 10.4.1.389 — fixed in 10.4.1.389
How to fix
Upgrade to a fixed version: PDF-XChange Editor 10.4.1.389. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0901 or the next vulnerability affects your stack