What’s Vulnerable › Vulnerabilities
CVE-2025-0914: Velociraptor Shell Plugin Prevent_execve Bypass
- Severity: low (CVSS 3.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-06-17
- Weakness: CWE-281
Description
An improper access control issue in the VQL shell feature in Velociraptor Versions < 0.73.4 allowed authenticated users to execute the execve() plugin in deployments where this was explicitly forbidden by configuring the prevent_execve flag in the configuration file. This setting is not usually recommended and is uncommonly used, so this issue will only affect users who do set it. This issue is fixed in release 0.73.4.
Affected products
- Rapid7 Velociraptor: before 0.73.4 — fixed in 0.73.4
How to fix
Upgrade to a fixed version: Rapid7 Velociraptor 0.73.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0914 or the next vulnerability affects your stack