What’s Vulnerable › Vulnerabilities
CVE-2025-0916: YaySMTP 2.4.9 - 2.6.2 - Unauthenticated Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-19 · updated 2026-06-17
- Weakness: CWE-79
Description
The YaySMTP and Email Logs: Amazon SES, SendGrid, Outlook, Mailgun, Brevo, Google and Any SMTP Service plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions 2.4.9 to 2.6.2 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Note: The vulnerability has been initially patched in version 2.4.8 and was reintroduced in version 2.4.9 with the removal of the wp_kses_post() built-in WordPress sanitization function.
Affected products
- YaySMTP – Simple WP SMTP Mail: from 2.4.9 before 2.6.3 — fixed in 2.6.3
How to fix
Upgrade to a fixed version: YaySMTP – Simple WP SMTP Mail 2.6.3. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/yaysmtp/trunk/includes/Functions.php
- https://plugins.trac.wordpress.org/browser/yaysmtp/trunk/includes/Helper/Utils.php
- https://plugins.trac.wordpress.org/changeset/3238172
- https://wordpress.org/plugins/yaysmtp/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/209019bd-b214-4389-a972-42e38d501203?source=cve
Get alerted when CVE-2025-0916 or the next vulnerability affects your stack