What’s Vulnerable › Vulnerabilities
CVE-2025-0935: Media Library Folders <= 8.3.0 - Missing Authorization to Plugin Settings Change
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-15 · updated 2026-06-17
- Weakness: CWE-862
Description
The Media Library Folders plugin for WordPress is vulnerable to unauthorized plugin settings change due to a missing capability check on several AJAX actions in all versions up to, and including, 8.3.0. This makes it possible for authenticated attackers, with Author-level access and above, to change plugin settings related to things such as IP-blocking.
Affected products
- maxfoundry Media Library Folders: before 8.3.1 — fixed in 8.3.1
How to fix
Upgrade to a fixed version: maxfoundry Media Library Folders 8.3.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/media-library-plus/trunk/media-library-plus.php#L6296
- https://plugins.trac.wordpress.org/browser/media-library-plus/trunk/media-library-plus.php#L697
- https://plugins.trac.wordpress.org/browser/media-library-plus/trunk/media-library-plus.php#L7198
- https://plugins.trac.wordpress.org/changeset/3234676/media-library-plus/trunk/media-library-plus.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6f810102-cf25-4898-a3a6-3cdc9a96aaea?source=cve
Get alerted when CVE-2025-0935 or the next vulnerability affects your stack