What’s Vulnerable › Vulnerabilities
CVE-2025-0937: Nomad Vulnerable To Event Stream Namespace ACL Policy Bypass Through Wildcard Namespace
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-12 · updated 2026-06-17
- Weakness: CWE-863
Description
Nomad Community and Nomad Enterprise ("Nomad") event stream configured with a wildcard namespace can bypass the ACL Policy allowing reads on other namespaces.
Affected products
- HashiCorp Nomad Enterprise: from 1.0.0 before 1.7.18; from 1.0.0 before 1.9.6; from 1.8.0 before 1.8.10; from 1.9.0 before 1.9.6 — fixed in 1.7.18, 1.8.10, 1.9.6
How to fix
Upgrade to a fixed version: HashiCorp Nomad Enterprise 1.7.18, 1.8.10, 1.9.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-0937 or the next vulnerability affects your stack