What’s Vulnerable › Vulnerabilities
CVE-2025-0958: Ultimate WordPress Auction Plugin <= 4.2.9 - Missing Authorization to Arbitrary Post Deletion
- Severity: medium (CVSS 6.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-04 · updated 2026-06-17
- Weakness: CWE-20
Description
The Ultimate WordPress Auction Plugin plugin for WordPress is vulnerable to unauthorized access to functionality in all versions up to, and including, 4.2.9. This makes it possible for authenticated attackers, with Contributor-level access and above, to delete arbitrary auctions, posts as well as pages and allows them to execute other actions related to auction handling.
Affected products
- nitesh_singh Ultimate WordPress Auction Plugin: before 4.3.0 — fixed in 4.3.0
How to fix
Upgrade to a fixed version: nitesh_singh Ultimate WordPress Auction Plugin 4.3.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ultimate-auction/trunk/ajax-actions/send-private-msg.php#L35
- https://plugins.trac.wordpress.org/browser/ultimate-auction/trunk/ultimate-auction.php#L219
- https://plugins.trac.wordpress.org/browser/ultimate-auction/trunk/ultimate-auction.php#L274
- https://plugins.trac.wordpress.org/changeset/3242416/ultimate-auction/trunk/ultimate-auction.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/af3675c9-3a6b-4139-85e8-2fc57f290e82?source=cve
Get alerted when CVE-2025-0958 or the next vulnerability affects your stack