What’s Vulnerable › Vulnerabilities
CVE-2025-0968: ElementsKit Elementor addons <= 3.4.0 - Unauthenticated Information Exposure via get_megamenu_content Function
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-19 · updated 2026-06-17
- Weakness: CWE-284
Description
The ElementsKit Elementor addons plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.4.0 due to a missing capability checks on the get_megamenu_content() function. This makes it possible for unauthenticated attackers to view any item created in Elementor, such as posts, pages and templates including drafts, trashed and private items.
Affected products
- Wpmet Elementskit Elementor Addons: before 3.4.1 — fixed in 3.4.1
How to fix
Upgrade to a fixed version: Wpmet Elementskit Elementor Addons 3.4.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/elementskit-lite/trunk/modules/megamenu/api.php#L47
- https://plugins.trac.wordpress.org/changeset/3237243/
- https://wordpress.org/plugins/elementskit-lite/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/432ac3b1-8f1d-442f-8e8d-62a1f26ba259?source=cve
Get alerted when CVE-2025-0968 or the next vulnerability affects your stack