What’s Vulnerable › Vulnerabilities
CVE-2025-10006: WPBakery Page Builder <= 8.6 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-18 · updated 2026-10-09
- Weakness: CWE-79
Description
The WPBakery Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'rev_slider_vc' shortcode in all versions up to, and including, 8.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is only exploitable when RevSlider is also installed.
Affected products
- WPBakery Page Builder: before 8.7 — fixed in 8.7
How to fix
Upgrade to a fixed version: WPBakery Page Builder 8.7. Check the vendor advisory for mitigations.
References
- https://kb.wpbakery.com/docs/preface/release-notes/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4d7b12e5-0de7-45f4-84e0-083818912623?source=cve
Get alerted when CVE-2025-10006 or the next vulnerability affects your stack