What’s Vulnerable › Vulnerabilities
CVE-2025-10016: Local Privilege Escalation in Sparkle Autoupdate Daemon
- Severity: high (CVSS 8.8 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-16 · updated 2026-10-19
- Weakness: CWE-863
Description
The Sparkle framework includes a helper tool Autoupdate. Due to lack of authentication of connecting clients a local unprivileged attacker can request installation of crafted malicious PKG file by racing to connect to the daemon when other app spawns it as root. This results in local privilege escalation to root privileges. It is worth noting that it is possible to spawn Autopudate manually via Installer XPC service. However this requires the victim to enter credentials upon system authorization dialog creation that can be modified by the attacker. This issue was fixed in version 2.7.2
Affected products
- Sparkle Project Sparkle: before 2.7.2 — fixed in 2.7.2
How to fix
Upgrade to a fixed version: Sparkle Project Sparkle 2.7.2. Check the vendor advisory for mitigations.
References
- https://cert.pl/en/posts/2025/09/CVE-2025-10015
- https://github.com/sparkle-project/Sparkle
- https://github.com/sparkle-project/Sparkle/discussions/2764
Get alerted when CVE-2025-10016 or the next vulnerability affects your stack