What’s Vulnerable › Vulnerabilities

CVE-2025-10023: A user with elevated privileges can inject XSS in the Services Meta-services configuration page

Description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Centreon Infra Monitoring (Services Meta-services modules) allows Stored XSS by users with elevated privileges.This issue affects Infra Monitoring: from 24.10.0 before 24.10.9, from 24.04.0 before 24.04.16, from 23.10.0 before 23.10.26.

Affected products

How to fix

Upgrade to a fixed version: Centreon 23.10.26, 24.04.16, 24.10.9. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-10023 or the next vulnerability affects your stack