What’s Vulnerable › Vulnerabilities
CVE-2025-10042: Quiz Maker <= 6.7.0.56 - Unauthenticated SQL Injection
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-17 · updated 2026-10-18
- Weakness: CWE-89
Description
The Quiz Maker plugin for WordPress is vulnerable to SQL Injection via spoofed IP headers in all versions up to, and including, 6.7.0.56 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. This is only exploitable in configurations where the server is set up to retrieve the IP from a user-supplied field like `X-Forwarded-For` and limit users by IP is enabled.
Affected products
- Ays Pro Quiz Maker: before 6.7.0.57 — fixed in 6.7.0.57
How to fix
Upgrade to a fixed version: Ays Pro Quiz Maker 6.7.0.57. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/quiz-maker/tags/6.7.0.52/public/class-quiz-maker-public.php
- https://plugins.trac.wordpress.org/browser/quiz-maker/tags/6.7.0.52/public/class-quiz-maker-public.php#L7145
- https://plugins.trac.wordpress.org/browser/quiz-maker/tags/6.7.0.57/public/class-quiz-maker-public.php#L7149
- https://www.wordfence.com/threat-intel/vulnerabilities/id/4eeae6dd-a41f-4878-aa92-064ec78367d7?source=cve
Get alerted when CVE-2025-10042 or the next vulnerability affects your stack