What’s Vulnerable › Vulnerabilities

CVE-2025-10060: MongoDB may be susceptible to Invariant Failure in Transactions due Upsert Operation

Description

MongoDB Server may allow upsert operations retried within a transaction to violate unique index constraints, potentially causing an invariant failure and server crash during commit. This issue may be triggered by improper WriteUnitOfWork state management. This issue affects MongoDB Server v6.0 versions prior to 6.0.25, MongoDB Server v7.0 versions prior to 7.0.22 and MongoDB Server v8.0 versions prior to 8.0.12

Affected products

How to fix

Upgrade to a fixed version: MongoDB 6.0.25, 7.0.22, 8.0.12. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-10060 or the next vulnerability affects your stack