What’s Vulnerable › Vulnerabilities
CVE-2025-10061: Malformed $group Query May Cause MongoDB Server to Crash
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-05 · updated 2026-06-17
- Weakness: CWE-20
Description
An authorized user can cause a crash in the MongoDB Server through a specially crafted $group query. This vulnerability is related to the incorrect handling of certain accumulator functions when additional parameters are specified within the $group operation. This vulnerability could lead to denial of service if triggered repeatedly. This issue affects MongoDB Server v6.0 versions prior to 6.0.25, MongoDB Server v7.0 versions prior to 7.0.22, MongoDB Server v8.0 versions prior to 8.0.12 and MongoDB Server v8.1 versions prior to 8.1.2
Affected products
- MongoDB: from 6.0.0 before 6.0.25; from 7.0.0 before 7.0.22; from 8.0.0 before 8.0.12; from 8.1.0 before 8.1.2 — fixed in 6.0.25, 7.0.22, 8.0.12, 8.1.2
How to fix
Upgrade to a fixed version: MongoDB 6.0.25, 7.0.22, 8.0.12, 8.1.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-10061 or the next vulnerability affects your stack