What’s Vulnerable › Vulnerabilities
CVE-2025-1014: Certificate length was not properly checked
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-04 · updated 2026-10-05
- Weakness: CWE-295
Description
Certificate length was not properly checked when added to a certificate store. In practice only trusted data was processed. This vulnerability was fixed in Firefox 135, Firefox ESR 128.7, Thunderbird 128.7, and Thunderbird 135.
Affected products
- Mozilla Firefox: before 128.7.0; before 135.0 — fixed in 128.7.0, 135.0
- Mozilla Thunderbird: from 128.0.1 before 128.7.0; from 131.0 before 135.0 — fixed in 128.7.0, 135.0
How to fix
Upgrade to a fixed version: Mozilla Firefox 128.7.0, 135.0; Mozilla Thunderbird 128.7.0, 135.0. Check the vendor advisory for mitigations.
References
- https://bugzilla.mozilla.org/show_bug.cgi?id=1940804
- https://www.mozilla.org/security/advisories/mfsa2025-07/
- https://www.mozilla.org/security/advisories/mfsa2025-09/
- https://www.mozilla.org/security/advisories/mfsa2025-10/
- https://www.mozilla.org/security/advisories/mfsa2025-11/
- https://lists.debian.org/debian-lts-announce/2025/02/msg00006.html
Get alerted when CVE-2025-1014 or the next vulnerability affects your stack