What’s Vulnerable › Vulnerabilities
CVE-2025-10157: PickleScan Bypasses Unsafe Globals Check Using Submodule Imports
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-17 · updated 2026-09-26
- Weakness: CWE-693
Description
A Protection Mechanism Failure vulnerability in mmaitre314 picklescan versions up to and including 0.0.30 allows a remote attacker to bypass the unsafe globals check. This is possible because the scanner performs an exact match for module names, allowing malicious payloads to be loaded via submodules of dangerous packages (e.g., 'asyncio.unix_events' instead of 'asyncio'). When the incorrectly considered safe file is loaded after scan, it can lead to the execution of malicious code.
Affected products
- picklescan: before 0.0.31 — fixed in 0.0.31
How to fix
Upgrade to a fixed version: picklescan 0.0.31. Check the vendor advisory for mitigations.
References
- https://github.com/mmaitre314/picklescan/blob/2a8383cfeb4158567f9770d86597300c9e508d0f/src/picklescan/scanner.py#L309
- https://github.com/mmaitre314/picklescan/security/advisories/GHSA-f7qq-56ww-84cr
- https://huggingface.co/iluem/linux_pkl/resolve/main/asyncio_asyncio_unix_events___UnixSubprocessTransport__start.pkl
Get alerted when CVE-2025-10157 or the next vulnerability affects your stack