What’s Vulnerable › Vulnerabilities
CVE-2025-10226: PostgreSQL Upgrade from v10 to v17.4 in AxxonSoft Axxon One (C-Werk) 2.0.8 and earlier to Address Multiple Vulnerabilities
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-10 · updated 2026-06-17
- Weakness: CWE-1395
Description
Dependency on Vulnerable Third-Party Component (CWE-1395) in the PostgreSQL backend in AxxonSoft Axxon One (C-Werk) 2.0.8 and earlier on Windows and Linux allows a remote attacker to escalate privileges, execute arbitrary code, or cause denial-of-service via exploitation of multiple known CVEs present in PostgreSQL v10.x, which are resolved in PostgreSQL 17.4.
Affected products
- AxxonSoft AxxonOne C-Werk: through 2.0.8
References
- https://www.axxonsoft.com/legal/axxonsoft-vulnerability-disclosure-policy/security-advisories
- https://www.postgresql.org/docs/release
Get alerted when CVE-2025-10226 or the next vulnerability affects your stack