What’s Vulnerable › Vulnerabilities
CVE-2025-1025
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 18.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-05 · updated 2026-06-17
- Weakness: CWE-434
Description
Versions of the package cockpit-hq/cockpit before 2.4.1 are vulnerable to Arbitrary File Upload where an attacker can use different extension to bypass the upload filter.
Affected products
- cockpit-hq/cockpit: before 2.4.1 — fixed in 2.4.1
How to fix
Upgrade to a fixed version: cockpit-hq/cockpit 2.4.1. Check the vendor advisory for mitigations.
References
- https://gist.github.com/CHOOCS/fe1227443544d5d74c33982814f290af
- https://github.com/Cockpit-HQ/Cockpit/commit/984ef9ad270357b843af63c81db95178eae42cae
- https://github.com/Cockpit-HQ/Cockpit/commit/becca806c7071ecc732521bb5ad0bb9c64299592
- https://security.snyk.io/vuln/SNYK-PHP-COCKPITHQCOCKPIT-8516320
- https://gist.github.com/CHOOCS/fe1227443544d5d74c33982814f290af
Get alerted when CVE-2025-1025 or the next vulnerability affects your stack