What’s Vulnerable › Vulnerabilities
CVE-2025-1026
- Severity: high (CVSS 8.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-05 · updated 2026-06-17
- Weakness: CWE-20
Description
Versions of the package spatie/browsershot before 5.0.5 are vulnerable to Improper Input Validation due to improper URL validation through the setUrl method, which results in a Local File Inclusion allowing the attacker to read sensitive files. **Note:** This is a bypass of the fix for [CVE-2024-21549](https://security.snyk.io/vuln/SNYK-PHP-SPATIEBROWSERSHOT-8533023).
Affected products
- spatie/browsershot: before 5.0.5 — fixed in 5.0.5
How to fix
Upgrade to a fixed version: spatie/browsershot 5.0.5. Check the vendor advisory for mitigations.
References
- https://gist.github.com/chuajianshen/6291920112fcf1543fa7b43862112be6
- https://gist.github.com/mrdgef/54a8783408220c67c1b859df38a52d65
- https://github.com/spatie/browsershot/commit/e3273974506865a24fbb5b65b534d8d4b8dfbf72
- https://github.com/spatie/browsershot/pull/908
- https://security.snyk.io/vuln/SNYK-PHP-SPATIEBROWSERSHOT-8533024
Get alerted when CVE-2025-1026 or the next vulnerability affects your stack