What’s Vulnerable › Vulnerabilities

CVE-2025-10280: Incorrect Content Type Cross-Site Scripting Vulnerability

Description

IdentityIQ 8.5, IdentityIQ 8.4 and all 8.4 patch levels prior to 8.4p4, IdentityIQ 8.3 and all 8.3 patch levels including 8.3p5, and all prior versions allows some IdentityIQ web services that provide non-HTML content to be accessed via a URL path that will set the Content-Type to HTML allowing a requesting browser to interpret content not properly escaped to prevent Cross-Site Scripting (XSS).

Affected products

How to fix

Upgrade to a fixed version: SailPoint IdentityIQ 8.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-10280 or the next vulnerability affects your stack