What’s Vulnerable › Vulnerabilities
CVE-2025-10316: Cross-Site Scripting in extension "Form to Database" (form_to_database)
- Severity: low (CVSS 2.3 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-16 · updated 2026-06-17
- Weakness: CWE-79
Description
The extension "Form to Database" is susceptible to Cross-Site Scripting. This issue affects the following versions: before 2.2.5, from 3.0.0 before 3.2.2, from 4.0.0 before 4.2.3, from 5.0.0 before 5.0.2.
Affected products
- TYPO3 Extension "Form to Database" (form_to_database): before 2.2.5; from 3.0.0 before 3.2.2; from 4.0.0 before 4.2.3; from 5.0.0 before 5.0.2 — fixed in 2.2.5, 3.2.2, 4.2.3, 5.0.2
How to fix
Upgrade to a fixed version: TYPO3 Extension "Form to Database" (form_to_database) 2.2.5, 3.2.2, 4.2.3, 5.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-10316 or the next vulnerability affects your stack