What’s Vulnerable › Vulnerabilities
CVE-2025-10360: Insufficiently Protected Credentials in Puppet Enterprise 2025.4 and 2025.5
- Severity: medium (CVSS 6.9 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-24 · updated 2026-09-26
- Weakness: CWE-522
Description
In Puppet Enterprise versions 2025.4.0 and 2025.5, the encryption key used for encrypting content in the Infra Assistant database was not excluded from the files gathered by Puppet backup. The key is only present on the system if the user has a Puppet Enterprise Advanced license and has enabled the Infra Assistant feature. The key is used for encrypting one particular bit of data in the Infra Assistant database: the API key for their AI provider account. This has been fixed in Puppet Enterprise version 2025.6, and release notes for 2025.6 have remediation steps for users of affected versions who can't update to the latest version.
Affected products
- Puppet Enterprise: from 2025.4 through 2025.5
References
Get alerted when CVE-2025-10360 or the next vulnerability affects your stack