What’s Vulnerable › Vulnerabilities
CVE-2025-1038
- Severity: high (CVSS 7.5 v4.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-28 · updated 2026-10-08
- Weakness: CWE-78
Description
The “Diagnostics Tools” page of the web-based configuration utility does not properly validate user-controlled input, allowing an authenticated user with high privileges to inject commands into the command shell of the TropOS 4th Gen device. The injected commands can be exploited to execute several set-uid (SUID) applications to ultimately gain root access to the TropOS device.
Affected products
- Hitachi Energy TropOS 4th Gen: from 8.7.0.0 before 8.9.6.0 — fixed in 8.9.6.0
How to fix
Upgrade to a fixed version: Hitachi Energy TropOS 4th Gen 8.9.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-1038 or the next vulnerability affects your stack