What’s Vulnerable › Vulnerabilities
CVE-2025-1040: Server-Side Template Injection (SSTI) in significant-gravitas/autogpt
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-1336
Description
AutoGPT versions 0.3.4 and earlier are vulnerable to a Server-Side Template Injection (SSTI) that could lead to Remote Code Execution (RCE). The vulnerability arises from the improper handling of user-supplied format strings in the `AgentOutputBlock` implementation, where malicious input is passed to the Jinja2 templating engine without adequate security measures. Attackers can exploit this flaw to execute arbitrary commands on the host system. The issue is fixed in version 0.4.0.
Affected products
- Significant-Gravitas AutoGPT: before 0.4.0 — fixed in 0.4.0
How to fix
Upgrade to a fixed version: Significant-Gravitas AutoGPT 0.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/significant-gravitas/autogpt/commit/6dba31e0215549604bdcc1aed24e3a1714e75ee2
- https://huntr.com/bounties/b74ef75f-61d5-4422-ab15-9550c8b4f185
- https://huntr.com/bounties/b74ef75f-61d5-4422-ab15-9550c8b4f185
Get alerted when CVE-2025-1040 or the next vulnerability affects your stack