What’s Vulnerable › Vulnerabilities
CVE-2025-10406: BlindMatrix e-Commerce < 3.1 - Contributor+ LFI
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-15 · updated 2026-10-08
- Weakness: CWE-22
Description
The BlindMatrix e-Commerce WordPress plugin before 3.1 does not validate some shortcode attributes before using them to generate paths passed to include function/s, allowing any authenticated users, such as contributors, to perform LFI attacks.
Affected products
- BlindMatrix e-Commerce: before 3.1 — fixed in 3.1
How to fix
Upgrade to a fixed version: BlindMatrix e-Commerce 3.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-10406 or the next vulnerability affects your stack