What’s Vulnerable › Vulnerabilities
CVE-2025-10493: Chained Quiz <= 1.3.5 - Unauthenticated Insecure Direct Object Reference via Cookie
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-18 · updated 2026-06-17
- Weakness: CWE-639
Description
The Chained Quiz plugin for WordPress is vulnerable to Insecure Direct Object Reference in version 1.3.4 and below via the quiz submission and completion mechanisms due to missing validation on a user controlled key. This makes it possible for unauthenticated attackers to hijack and modify other users' quiz attempts by manipulating the chained_completion_id cookie value, allowing them to alter quiz answers, scores, and results of any user. The vulnerability was partially patched in versions 1.3.4 and 1.3.5.
Affected products
- prasunsen Chained Quiz: through 1.3.5
References
- https://plugins.trac.wordpress.org/browser/chained-quiz/tags/1.3.3/controllers/quizzes.php
- https://plugins.trac.wordpress.org/browser/chained-quiz/tags/1.3.3/models/quiz.php
- https://plugins.trac.wordpress.org/changeset/3362561/
- https://plugins.trac.wordpress.org/changeset/3362701/
- https://plugins.trac.wordpress.org/changeset/3362966/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1d8f6965-1fe3-4f24-bd6b-9026e91bc5db?source=cve
Get alerted when CVE-2025-10493 or the next vulnerability affects your stack