What’s Vulnerable › Vulnerabilities
CVE-2025-10498: Ninja Forms – The Contact Form Builder That Grows With You <= 3.12.0 - Cross-Site Request Forgery to Limited File Deletion
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-27 · updated 2026-10-09
- Weakness: CWE-352
Description
The Ninja Forms – The Contact Form Builder That Grows With You plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.12.0. This is due to missing or incorrect nonce validation when exporting CSV files. This makes it possible for unauthenticated attackers to delete those files granted they can trick an administrator into performing an action such as clicking on a link.
Affected products
- kstover Ninja Forms – The Contact Form Builder That Grows With You: before 3.12.1 — fixed in 3.12.1
How to fix
Upgrade to a fixed version: kstover Ninja Forms – The Contact Form Builder That Grows With You 3.12.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/ninja-forms/trunk/includes/Admin/Menus/Submissions.php#L464
- https://plugins.trac.wordpress.org/changeset/3365881/ninja-forms/trunk?contextall=1&old=3362375&old_path=%2Fninja-forms%2Ftrunk#file6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b082176c-9486-416c-8215-cdba4d6e5260?source=cve
Get alerted when CVE-2025-10498 or the next vulnerability affects your stack