What’s Vulnerable › Vulnerabilities
CVE-2025-10568: HyperX NGENUITY - Arbitrary Code Execution
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-19 · updated 2026-06-17
- Weakness: CWE-78
Description
HyperX NGENUITY software is potentially vulnerable to arbitrary code execution. HP is releasing updated software to address the potential vulnerability.
Affected products
- Hyperx Ngenuity: before 5.32.0.0 — fixed in 5.32.0.0
How to fix
Upgrade to a fixed version: Hyperx Ngenuity 5.32.0.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-10568 or the next vulnerability affects your stack