What’s Vulnerable › Vulnerabilities
CVE-2025-10585: Google Chromium V8 Type Confusion Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2025-09-23
- EPSS: 6.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-24 · updated 2026-07-14
- Weakness: CWE-843
Description
Type confusion in V8 in Google Chrome prior to 140.0.7339.185 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)
Affected products
- Google Chrome: before 140.0.7339.185 — fixed in 140.0.7339.185
- Siemens Cadra: all versions
How to fix
Upgrade to a fixed version: Google Chrome 140.0.7339.185. Check the vendor advisory for mitigations.
References
- https://chromereleases.googleblog.com/2025/09/stable-channel-update-for-desktop_17.html
- https://issues.chromium.org/issues/445380761
- https://cert-portal.siemens.com/productcert/html/ssa-470355.html
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2025-10585
Get alerted when CVE-2025-10585 or the next vulnerability affects your stack