What’s Vulnerable › Vulnerabilities
CVE-2025-1064: Login/Signup Popup ( Inline Form + Woocommerce ) <= 2.8.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via xoo_el_action Shortcode
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-20 · updated 2026-06-17
- Weakness: CWE-79
Description
The Login/Signup Popup ( Inline Form + Woocommerce ) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's xoo_el_action shortcode in all versions up to, and including, 2.8.5 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- xootix Login & Register Customizer – Popup | Slider | Inline | WooCommerce: before 2.8.6 — fixed in 2.8.6
How to fix
Upgrade to a fixed version: xootix Login & Register Customizer – Popup | Slider | Inline | WooCommerce 2.8.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3239293/easy-login-woocommerce
- https://www.wordfence.com/threat-intel/vulnerabilities/id/dd62a072-8619-4f51-a52f-2ada7e455cb1?source=cve
Get alerted when CVE-2025-1064 or the next vulnerability affects your stack