What’s Vulnerable › Vulnerabilities
CVE-2025-10868: Business Logic Errors in GitLab
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-26 · updated 2026-10-19
- Weakness: CWE-840
Description
An issue has been discovered in GitLab CE/EE affecting all versions from 17.4 before 18.2.7, 18.3 before 18.3.3, and 18.4 before 18.4.1 where certain string conversion methods exhibit performance degradation with large inputs.
Affected products
- GitLab: from 17.4.0 before 18.2.7; from 18.3.0 before 18.3.3; 18.4.0 — fixed in 18.2.7, 18.3.3
How to fix
Upgrade to a fixed version: GitLab 18.2.7, 18.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-10868 or the next vulnerability affects your stack