What’s Vulnerable › Vulnerabilities

CVE-2025-10871: Missing Authorization in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions from 16.6 before 18.2.7, 18.3 before 18.3.3, and 18.4 before 18.4.1. Project Maintainers can exploit a vulnerability where they can assign custom roles to users with permissions exceeding their own, effectively granting themselves elevated privileges.

Affected products

How to fix

Upgrade to a fixed version: GitLab 18.2.7, 18.3.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2025-10871 or the next vulnerability affects your stack