What’s Vulnerable › Vulnerabilities
CVE-2025-10916: FormGent < 1.0.4 - Unauthenticated Arbitrary File Deletion
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-21 · updated 2026-10-08
Description
The FormGent WordPress plugin before 1.0.4 is vulnerable to arbitrary file deletion due to insufficient file path validation. This makes it possible for unauthenticated attackers to delete arbitrary files on the server.
Affected products
- FormGent: before 1.0.4 — fixed in 1.0.4
How to fix
Upgrade to a fixed version: FormGent 1.0.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/81c23998-1abb-495f-890a-79624a4cab9a/
- https://wpscan.com/vulnerability/81c23998-1abb-495f-890a-79624a4cab9a/
Get alerted when CVE-2025-10916 or the next vulnerability affects your stack