What’s Vulnerable › Vulnerabilities
CVE-2025-10931: Umami Analytics - Moderately critical - Cross Site Scripting - SA-CONTRIB-2025-109
- Severity: low (CVSS 3.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-30 · updated 2026-10-08
- Weakness: CWE-79
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Drupal Umami Analytics allows Cross-Site Scripting (XSS).This issue affects Umami Analytics: from 0.0.0 before 1.0.1.
Affected products
- Drupal Umami Analytics: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: Drupal Umami Analytics 1.0.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-10931 or the next vulnerability affects your stack