What’s Vulnerable › Vulnerabilities
CVE-2025-1094: PostgreSQL quoting APIs miss neutralizing quoting syntax in text that fails encoding validation
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 90.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-13 · updated 2026-06-17
- Weakness: CWE-149
Description
Improper neutralization of quoting syntax in PostgreSQL libpq functions PQescapeLiteral(), PQescapeIdentifier(), PQescapeString(), and PQescapeStringConn() allows a database input provider to achieve SQL injection in certain usage patterns. Specifically, SQL injection requires the application to use the function result to construct input to psql, the PostgreSQL interactive terminal. Similarly, improper neutralization of quoting syntax in PostgreSQL command line utility programs allows a source of command line arguments to achieve SQL injection when client_encoding is BIG5 and server_encoding is one of EUC_TW or MULE_INTERNAL. Versions before PostgreSQL 17.3, 16.7, 15.11, 14.16, and 13.19 are affected.
Affected products
- PostgreSQL: from 17 before 17.3; from 16 before 16.7; from 15 before 15.11; from 14 before 14.16; before 13.19 — fixed in 13.19, 14.16, 15.11, 16.7, 17.3
How to fix
Upgrade to a fixed version: PostgreSQL 13.19, 14.16, 15.11, 16.7. Check the vendor advisory for mitigations.
References
- https://www.postgresql.org/support/security/CVE-2025-1094/
- http://www.openwall.com/lists/oss-security/2025/02/16/3
- http://www.openwall.com/lists/oss-security/2025/02/20/1
- https://lists.debian.org/debian-lts-announce/2025/02/msg00015.html
- https://lists.debian.org/debian-lts-announce/2025/02/msg00024.html
- https://security.netapp.com/advisory/ntap-20250221-0010/
Get alerted when CVE-2025-1094 or the next vulnerability affects your stack