What’s Vulnerable › Vulnerabilities
CVE-2025-11012: BehaviorTree Diagnostic Message script_parser.cpp ParseScript stack-based overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-09-26 · updated 2026-10-19
- Weakness: CWE-119
Description
A vulnerability was determined in BehaviorTree up to 4.7.0. This affects the function ParseScript of the file /src/script_parser.cpp of the component Diagnostic Message Handler. Executing manipulation of the argument error_msgs_buffer can lead to stack-based buffer overflow. The attack can only be executed locally. The exploit has been publicly disclosed and may be utilized. This patch is called cb6c7514efa628adb8180b58b4c9ccdebbe096e3. A patch should be applied to remediate this issue.
Affected products
- BehaviorTree: before 4.7.3 — fixed in 4.7.3
How to fix
Upgrade to a fixed version: BehaviorTree 4.7.3. Check the vendor advisory for mitigations.
References
- https://github.com/BehaviorTree/BehaviorTree.CPP/commit/cb6c7514efa628adb8180b58b4c9ccdebbe096e3
- https://github.com/BehaviorTree/BehaviorTree.CPP/issues/1006
- https://github.com/BehaviorTree/BehaviorTree.CPP/pull/1007
- https://github.com/user-attachments/files/22251337/poc.zip
- https://vuldb.com/?ctiid.325955
- https://vuldb.com/?id.325955
- https://vuldb.com/?submit.654074
Get alerted when CVE-2025-11012 or the next vulnerability affects your stack