What’s Vulnerable › Vulnerabilities
CVE-2025-11093: Arbitrary Code Execution with higher privileged users in Multiple WSO2 Products via Script Mediator Engines (GraalJS and NashornJS)
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-11-05 · updated 2026-06-17
- Weakness: CWE-94
Description
An arbitrary code execution vulnerability exists in multiple WSO2 products due to insufficient restrictions in the GraalJS and NashornJS Script Mediator engines. Authenticated users with elevated privileges can execute arbitrary code within the integration runtime environment. By default, access to these scripting engines is limited to administrators in WSO2 Micro Integrator and WSO2 Enterprise Integrator, while in WSO2 API Manager, access extends to both administrators and API creators. This may allow trusted-but-privileged users to perform unauthorized actions or compromise the execution environment.
Affected products
- WSO2 Api Control Plane: from 4.5.0 before 4.5.0.29 — fixed in 4.5.0.29
- WSO2 API Manager: from 3.1.0 before 3.1.0.345; from 3.2.0 before 3.2.0.446; from 3.2.1 before 3.2.1.66; from 4.1.0 before 4.1.0.228; from 4.2.0 before 4.2.0.169; from 4.3.0 before 4.3.0.81 — fixed in 3.1.0.345, 3.2.0.446, 3.2.1.66, 4.1.0.228, 4.2.0.169, 4.3.0.81
- WSO2 Enterprise Integrator: from 6.6.0 before 6.6.0.224 — fixed in 6.6.0.224
- WSO2 Micro Integrator: from 4.0.0 before 4.0.0.145; from 4.1.0 before 4.1.0.147; from 4.2.0 before 4.2.0.141; from 4.3.0 before 4.3.0.42; from 4.4.0 before 4.4.0.27 — fixed in 4.0.0.145, 4.1.0.147, 4.2.0.141, 4.3.0.42, 4.4.0.27
- WSO2 Traffic Manager: from 4.5.0 before 4.5.0.27 — fixed in 4.5.0.27
- WSO2 Universal Gateway: from 4.5.0 before 4.5.0.27 — fixed in 4.5.0.27
How to fix
Upgrade to a fixed version: WSO2 Api Control Plane 4.5.0.29; WSO2 API Manager 3.1.0.345, 3.2.0.446, 3.2.1.66, 4.1.0.228; WSO2 Enterprise Integrator 6.6.0.224; WSO2 Micro Integrator 4.0.0.145, 4.1.0.147, 4.2.0.141, 4.3.0.42; WSO2 Traffic Manager 4.5.0.27; WSO2 Universal Gateway 4.5.0.27. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2025-11093 or the next vulnerability affects your stack